Website is slow

Incident Report for Translucent Demo

Resolved

We have fixed the poor performance.
Posted Feb 28, 2022 - 10:08 CET

Identified

We have found an error in the back-end and will be applying a fix.
Posted Feb 28, 2022 - 10:02 CET

Investigating

We are experiencing outages. Please stand by for updates.
Posted Feb 28, 2022 - 10:00 CET
This incident affected: Customer facing applications (Website).